Play Free Realms NowJoin Free Realms Insider

Results 1 to 4 of 4
  1. #1
    Austin972 is offline Newbie Explorer
    Join Date
    Dec 2010
    Posts
    1

    Default Why Does Free Realms Freeze On My Laptop?

    This Is My First Post So Hi But I Came To Ask Something; Why Does My Laptop Running On Windows 7 Freeze While Playing Freerealms? And How Can I Fix It?
    ~Austin~

  2. #2
    Karennn's Avatar
    Karennn is offline Master Gamer
    Join Date
    Jun 2010
    Posts
    1,202

    Default Re: Why Does Free Realms Freeze On My Laptop?

    It could be because your laptop/pc may be old, old computers usually don't run at the same capacity compared to a new one, newer ones are created for games and to store bigger files

    Another reason could be that your memory drive may be full, if you have a lot of programs installed in your drive, it starts running slower so you can delete the ones you don't normally use

    Also, your browser could have gathered and saved up history datas and cookies that you need to clear up.

    Having a slow internet connection could be another reason


  3. #3
    randomgirl's Avatar
    randomgirl is offline Amateur Gamer
    Join Date
    Sep 2010
    Posts
    374

    Default Re: Why Does Free Realms Freeze On My Laptop?

    Well they're could be many reasons... Your internet connection could be low.... Your PC/Laptop could be very old... Free Realms may not be Plugged in...

  4. #4
    Grim Soulreaper's Avatar
    Grim Soulreaper is offline Master Gamer
    Join Date
    Jan 2011
    Posts
    1,478

    Default Re: Why Does Free Realms Freeze On My Laptop?

    I am working on that same problem... this is what helped me : ( from FR Tech support)

    Make sure you are not running any programs on your windows taskbar. If the problem persists, you should try running your system under a clean boot as this will prevent any hidden programs from loading.

    To disable background programs:

    1. Select the START button.
    2. Select RUN, then type in "msconfig" (for Vista, type msconfig in the search bar at the bottom of the Start Menu)
    3. Press OK
    4. Select the STARTUP tab.
    5. Click the DISABLE ALL button.
    6. Hit apply and then OK. Restart the computer and try the game again.

    If you are still experiencing the same issue, please reply back.
    Playing DCUO now


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •